Resolved
We believe this was caused downstream by Cloudflare, as indicated by their status page. It should be resolved now.
Monitoring
Our platform is back to normal speeds. We are monitoring and making adjustments to ensure it stays very fast.
Investigating
We are investigating reports of the Whop website and mobile app being slower than normal. We are working to speed it up now.