No components marked as affected
Resolved
All issues are resolved. You may use Splitit.
Monitoring
The errors seem to be resolved. We are monitoring on our side.
Monitoring
Downstream errors went down to zero, we believe Splitit fixed something on their side. We are still monitoring.
Identified
We have identified that the issue is an error in Splitit's infrastructure. Their team is investigating. We will publish further updates as we receive them.
Investigating
Splitit payment plans are currently experiencing issues at checkout. We are investigating the issue. Please use another payment option in the meantime.