Resolved
Discord access is now instant.
Monitoring
We expect the issue to be resolved. Please contact our live chat support if issues persist. Thank you for your patience.
Identified
We are deploying a fix. We expect the Discord app to be operating normally very shortly.
Identified
When trying to join a Discord server or claim Discord roles, it may take longer than expected. Our system is currently backed up and reaching Discord API rate limits. We are making changes to fix this.